Notion MCP integration connection handshake timeouts during workspace linking
Resolved
Jul 1, 2026 at 7:08pm UTC
We have identified the root cause of the Notion connection issue and confirmed it is entirely external. Our logs show a 2+ minute gap of zero activity on our servers after navigating to the authentication pages at mcp.notion.com, with no callback ever being received from their system.
Since this issue is happening entirely on Notion's own MCP service, it is outside of our codebase's control. We are monitoring their service status and will update here as soon as their authentication pages are stable again. The main BrainUs AI chat remains fully operational.
Affected services
Created
Jul 1, 2026 at 3:01pm UTC
We're investigating an issue with our Notion integration that is preventing some users from successfully linking their workspaces to BrainUs AI. The problem occurs during the connection handshake phase, resulting in a timeout error when the system attempts to sync.
Our main AI chat and core study tools remain fully operational. We're actively working to resolve the connection issue as quickly as possible and will share another update shortly.
Affected services