Back to overview
Degraded

Redis cache validation error when caching messages with null citation fields

Nov 27 at 03:35pm +0530
Affected services
Backend API
Chat Interface

Resolved
Nov 27 at 09:46pm +0530

Chat is fully back to normal! We’ve fixed the Redis validation issue by making it tolerant of older messages with incomplete citations. All conversations are now loading and saving correctly, and caching is working as intended.

Updated
Nov 27 at 03:43pm +0530

We've pinpointed the cause of the chat outage: our new Redis caching system is rejecting older conversation messages that contain incomplete document citations, such as missing file names or IDs. This validation error is blocking the entire chat process, preventing users from sending or saving new messages

Created
Nov 27 at 03:35pm +0530

We're investigating an issue with our chat system that is preventing users from sending messages. The problem occurs when the system tries to process conversations that reference certain documents.

We're working to fix the problem as quickly as we can. We'll share another update shortly.